Unalble to Login Into Classroom
Incident Report for Freckle
Resolved
This incident has been resolved.
Posted Sep 11, 2024 - 17:47 UTC
Investigating
We are currently investigating this issue.
Posted Sep 11, 2024 - 16:56 UTC
This incident affected: Teacher.