Elevated Error Rate
Incident Report for Freckle
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 17:17 UTC
Update
The system has returned to normal.
Posted Mar 15, 2024 - 16:01 UTC
Update
We are continuing to investigate this issue, and are continuing to monitor the situation.
Posted Mar 14, 2024 - 16:35 UTC
Investigating
We are investigating a higher than normal number of errors.
Posted Mar 14, 2024 - 03:58 UTC
This incident affected: Student, Teacher, and School.