Classroom site outage
Incident Report for Freckle
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 19:03 UTC
Investigating
We're experiencing errors accessing classroom.freckle.com. We are investigating and will provide more details soon.
Posted Jan 25, 2023 - 18:57 UTC
This incident affected: Teacher.