Freckle landing page down
Incident Report for Freckle
Resolved
This incident has been resolved.
Posted Sep 30, 2021 - 01:00 UTC
Investigating
Our 3rd party hosting provider for our landing page at freckle.com is having an outage. We will monitor the situation and provide updates as we have them.
Posted Sep 29, 2021 - 23:54 UTC
This incident affected: Freckle.com.