Users logged out and unable to log in
Incident Report for Freckle
Resolved
Issue has been resolved.
Posted Jun 20, 2024 - 19:02 UTC
Monitoring
We are investigating the issue, and have determined that it should resolve itself shortly.
Posted Jun 20, 2024 - 17:36 UTC
This incident affected: Student, Teacher, and School.