Freckle landing page down

Incident Report for Freckle

Resolved

This incident has been resolved.
Posted Jun 21, 2022 - 07:19 UTC

Monitoring

The 3rd party hosting provider for our landing page at freckle.com is having an outage. We will monitor the situation and provide updates as we have them.
Posted Jun 21, 2022 - 07:07 UTC
This incident affected: Freckle.com.