Student site outage
Incident Report for Freckle
Resolved
This incident has been resolved.
Posted Apr 28, 2022 - 20:18 UTC
Investigating
We're experiencing errors accessing student.freckle.com. We are investigating and will provide more details soon.
Posted Apr 28, 2022 - 20:15 UTC
This incident affected: Student.