Student site outage

Incident Report for Freckle

Resolved

This incident has been resolved.
Posted Jul 28, 2022 - 17:33 UTC

Investigating

We're experiencing errors accessing student.freckle.com. We are investigating and will provide more details soon.
Posted Jul 28, 2022 - 17:26 UTC
This incident affected: Student.